Наследование модулей альтернативных версий PHP в ISPmanager 5 Business

Малинкин Михаил добавил(а) 4 года назад
Решена

Здравствуйте. Столкнулись со следующей сложностью в работе, которую, в нашем случае, вынужден отнести к категории ошибок. Поясню на примере. Пользователь не может подключить, например, nd_pdo_mydql расширение на альтернативной версии PHP. Получает сообщение, что нужно отключить pdo_mysql, который на самом деле отключён. https://s.mail.ru/6WUw/zuBCG6oWg Всё дело в том, что pdo_mysql включён в глобальных настройках https://s.mail.ru/Lxyn/c4hESnAb1 , а это, как выяснилось, так и было задумано. Что root-пользователь, являясь администратором сервера, определяет сам, какие модули PHP будут включены у всех пользователей изначально.Но, обычно, в большинстве известных мне систем такого наследования нет. Поясню - наследуется включённое состояние расширения. Это правильно. Но, при отключении его у пользователя, оно и должно отключаться для данного конкретного пользователя. А этого не происходит, что, на мой взгляд, уже не правильно. Я не могу глобально отключить приведённое в примере расширение pdo_mysql, т.к. оно необходимо другим пользователям, но из-за этого не могу включить расширение nd_pdo_mydql для отдельно взятого пользователя. Соответственно, мы теряем клиента.

Комментарии (3)

фото
3

Добрый день.

Проблема подтверждена и передана разработчикам на исправление

фото
3

исправление выйдет в beta версии 12 декабря и stable 19 декабря

фото
1

Благодарю за решение. Ждём выхода обновления.