ISPmanager LITE удаляет apache самовольно.

worker добавил(а) 3 года назад
Support issue

Здравствуйте!


Уже не в первый раз наблюдаю такую ситуацию.

При обновление панели и последующем выполнение действия по установки php новой версии, которой не было в старой версии панели, удаляется apache.

Обновление и установка php производится через командную утилиту mgrctl. Скрипты эти доступны службе поддержки ISP.


Проблему наблюдал при обновление на версию 5.109 и сейчас при обновление до версии 5.144.

Комментарии (1)

фото
1

Здравствуйте. Провели тестирование с запуском вашего скрипта на 10 стендах со следующими параметрами:

512 МБ 1 ядро

1024 МБ 2 ядра

8 ГБ 8 ядер

32 ГБ 16 ядер

ОС: Centos 7

Проблема с удалением Apache не воспроизвелась. Также в скрипте перед циклом установки PHP желательно обновлять панель следующей командой:

/usr/local/mgr5/sbin/pkgupgrade.sh coremanager (обновятся только пакеты панели)

Команда не должна входить в циклы. Выполняется данная команда, а потом можно запускать ваш цикл по установке PHP.

фото
1

Здравствуйте!

Посмотрел мои обращения, нашел обращение 10654296 от 27-07-2017 там я сё описывал и ваш коллега ответил так в одном из сообщений:

"Ошибка для разработчика зарегистрирована, но пока Вам нужно придерживаться этим рекомендациям."

Получает ошибка, то была и это относилось к версии 5.109

Пожалуйста в комментаиях делайте привязку к версии панели, а то год прошёл. Также в обращение я описывал что сначло я обновлял панели а затем уже устанавливал php и это подтверждает ваши слова, что сначало надо обновить, а потом цикл делать.


Спасибо за информацию.

фото