Mysql Governor Cloudlinux 8

Jumuro добавил(а) 12 мес. назад
Известна

На Cloudlinux 8 не получится включить (установить) db_governor

Причина в том, что mysql в centos 8 сейчас имеет версию 8.0.21, а в CL последняя версия (в бэте) 8.0.20 и скрипт установки db_governor валится с ошибкой, естественно.

А вообще, дайте нам возможность использовать в ISPmanager Business на Centos 8 MariaDB, вместо MySQL!

Раньше вы не давали этого, т.к. MariaDB не было в стандартных репах. В Centos 8 MariaDB уже ЕСТЬ в СТАНДАРТНЫХ репах.

Дайте возможность ее использовать!

Комментарии (5)

фото
1

Кроме того pdns требует mariadb-connector-c

Если таки установить db_governor (с понижением версии mysql до 8.0.19 (если не использовать cl-beta)), то pdns работать перестает.

Ставим вручную mariadb-connector-c и это понижает mysql до версии 8.0.18.

И после всего этого (включения db governor) определение версии mysql на главной странице панели не работает (привет из стааарой темы)


Сплошные танцы с бубном.

Сделайте нормальную поддержку MariaDB), вместо MySQL 8. Ведь она теперь есть в стандартных репах и ваши аргументы, связанные с этим, более не актуальны.

На данный момент полноценный переход на CloudLinux 8 НЕВОЗМОЖЕН (но поддержка вами заявлена)!

фото
1

Ну или если даже оставить MySQL 8, то хотя-бы решите вопрос с Governor.

Фактически, он не устанавливается.

И Решите проблему отображения версии MySQL, если установлен Governor.

фото
1

В скрипте вы передаете --install, а нужно --install-beta

фото
1

Кроме того:

https://docs.cloudlinux.com/cloudlinux_os_components/#installation

Starting with MySQL Governor version 1.2 when installing MySQL/MariaDB MySQL Governor asks for a confirmation of a database version to be installed. To avoid such behavior for the automatic installations, please use --yes flag.

/usr/share/lve/dbgovernor/mysqlgovernor.py --install --yes

фото
1

Пообщался с разработчиками CloudLinux.

В общем, если уж не даете MariaDB, то для CL8 при установке DB Governor вам достаточно использовать команду с аргументами --install-beta --yes

/usr/share/lve/dbgovernor/mysqlgovernor.py --install-beta --yes

вместо простого --install, как сейчас.